ファイルをアップロード
対象アプリ:Workflow、Chatflow。
この環境のこのアプリへのリクエストで使うファイルをアップロードします。
返される id が使えるのは、同じ user を持ち、同じアプリと環境に対するリクエストだけです。1 回の実行が参照できるファイルは最大 100 個です。
標準 API の対応する操作:ファイルをアップロード。相違点は次のとおりです。
userが必須です。- レスポンスの
source_urlは署名付きのダウンロード URL です。 userフィールドより前に届いたすべてのパートの合計サイズは、100 MiB が上限です。- エラーコードが異なります。
承認
すべてのリクエストは API キーで認証します:Authorization: Bearer {API_KEY}。アプリのエンドポイントにはアプリの API キーを、ナレッジのエンドポイントにはナレッジベースの API キーを使用します(Dify API クイックスタート)。
キーはサーバーサイドで保管し、クライアントコードには決して埋め込まないでください。キーが欠落または無効なリクエストは HTTP 401(unauthorized)で失敗します。
ボディ
ファイルアップロードリクエスト。multipart/form-data 形式が必要です。
アップロードするファイル。multipart/form-data の 1 パートとして送信します。ファイル名に / や \ は使えません。
デプロイの安全ブラックリスト(UPLOAD_FILE_EXTENSION_BLACKLIST、デフォルトは空)にある拡張子を除き、任意の拡張子を受け付けます。
サイズ上限のデフォルト値はカテゴリごとに、画像 5 MB、音声 50 MB、動画 100 MB、その他のファイル 15 MB です。Docker Compose でデプロイした場合、画像の上限は 10 MB です。これらの上限は、プラットフォームの管理者が UPLOAD_*_FILE_SIZE_LIMIT 環境変数 で変更できます。
エンドユーザーの識別子。アプリ側で定義し、アプリ内で一意にします。ファイルは、このアプリとこの環境における user に属します。このパートは file より前に送信することを推奨します。それより前に届いたパートの合計サイズは 100 MiB が上限です。エンドユーザーの識別 を参照してください。
512レスポンス
保存されたファイルです。id は実行時の参照に使います。
一意のファイル ID。
Agent やツールのコンテキストでファイルを添付する際に内部的に使用される不透明なファイル参照です。このエンドポイントでアップロードされたファイルでは常に null です。
ファイル名。
ファイルサイズ(バイト)。
ファイル拡張子。
ファイルの MIME タイプ。
アップロードタイムスタンプ(Unix エポック秒)。
ファイルのプレビュー URL。
ファイルの署名付きダウンロード URL です。
ファイルの元の URL。
未使用です。常に null になります。
関連付けられたテナントの ID。
関連付けられた会話の ID。
未使用です。常に null になります。