Skip to main content
環境画面では、アプリの実行環境を作成・管理し、リソースの割り当て、アプリの状態やデプロイ履歴の確認を行えます。 環境管理は Kubernetes(Helm)デプロイモードでのみ利用可能であり、Docker Compose デプロイではサポートされていません。
環境一覧のカードビュー

リソースモデルとモード

プラットフォームの CPU 総クォータはライセンスによって決定されます。環境の作成時に、プラットフォームの利用可能クォータから CPU 割り当て を設定します。この割り当てが、環境内のアプリが使用する CPU リソースプールになります。 環境内にアプリがデプロイされているかどうかにかかわらず、環境に割り当てられたクォータはプラットフォームの割り当て済みクォータに計上されます。失敗した環境や削除中の環境は計上されません。共有モードと分離モードのどちらも所属環境のリソースプールを使用しますが、アプリの実行方法とプール内リソースの割り当て方法が異なります。 例えば、プラットフォームの総クォータを 24 vCPU とします。CPU 割り当てが 4 vCPU の環境を作成すると、他の環境に割り当てられる残量は 20 vCPU になります。
  • 共有モード:環境内のすべてのアプリがこの 4 vCPU を共有します。
  • 分離モード:アプリ A とアプリ B にそれぞれ 1 vCPU を割り当てた後、環境のリソースプールには 2 vCPU の空きが残ります。プラットフォームの利用可能クォータは依然として 20 vCPU のままであり、アプリへの割り当てによってさらに差し引かれることはありません。
CPU 割り当てはリソースの割り当て上限を示すものであり、現在の実際の CPU 使用量を表すものではありません。空の分離環境が、環境クォータ全体を占有する App Runner をあらかじめ起動することはありません。 環境のモードは作成後に変更できません。環境の CPU 割り当ては後から調整できますが、分離モードでは各アプリに割り当て済みの CPU 合計を下回ることはできません。メモリはライセンスの CPU クォータによる制限を受けませんが、フォームに表示される下限を満たし、クラスターのリソースが十分であることを確認する必要があります。

環境の作成

画面右上の 環境を作成 をクリックし、以下の情報を入力します: 設定が完了したら、環境を作成 をクリックします。
共有環境の作成とリソース設定
作成した環境はまず 作成中 と表示され、デプロイを受け付けられる状態になると 準備完了 に変わります。以降は、アプリをデプロイ 権限を持つメンバーがこの環境にアプリをデプロイできます。 初期化でエラーが発生した場合、環境は 失敗 ステータスになります。ステータスタグにカーソルを合わせると原因を確認できます。失敗した環境の再試行はサポートされていないため、トラブルシューティングを行ってから削除し、再度作成してください。

環境のステータス

環境一覧は カード と テーブル の 2 つのビューに対応しており、リソースの割り当て状況や過去 24 時間の実行メトリクスが表示されます:
  • 24時間の呼び出し と エラー率:エラー率は、呼び出し総数に対する失敗呼び出し数の割合です。過去 24 時間に呼び出しがない場合、エラー率には — が表示されます。
  • CPU 割り当て:分離モードでは「割り当て済み / クォータ」形式で表示され、リソースプールの割り当て状況を確認できます。共有モードでは割り当てられたクォータのみが表示されます。
  • 24時間の失敗デプロイ:数字をクリックすると、デプロイ履歴 でそれらのデプロイと失敗の原因を確認できます。
環境をクリックして詳細ページを開きます。アプリ タブにアプリごとの 実行状態、現在のバージョン、この環境の24時間の呼び出し が表示されます。最新の公開バージョンより古い場合、現在のバージョン の横に「公開済みの最新バージョンより N バージョン遅れ」と表示されます。更新するには再デプロイが必要です。
共有環境内のアプリと実行状態
呼び出し数とエラー率は集計メトリクスです。個別の呼び出しのステータス、実行時間、Token 数、エラーメッセージを確認したい場合は、呼び出しログ を開き、環境でフィルターをかけてください。

デプロイ履歴

環境の詳細ページで デプロイ タブを開きます。アプリ、時間範囲(デフォルトは 過去7日間)、操作の種類、ステータスでフィルターをかけることができます。
環境のデプロイ履歴とフィルター条件
失敗した記録を展開すると、エラーコードやエラーメッセージを含む 失敗の原因 を確認・コピーできます。実行者 にはデプロイを実行したユーザーが表示されます。 分離環境でリソースが不足していると、デプロイが失敗することがあります。アプリを分離環境にデプロイする際はデフォルトで 0.5 vCPU が割り当てられます。リソースプールの残量が 0.5 vCPU 未満の場合、デプロイは失敗します。環境の CPU 割り当て を引き上げるか、アプリごとのリソース調整 で他のアプリの CPU を減らしてから、アプリを再デプロイしてください。

環境の編集

環境カード、テーブル行の末尾、または詳細ページの右上にある … メニューから 編集 を選択します。名前、説明、リソース設定を変更できます。モードと名前空間は作成後に変更できません。これらを変更する必要がある場合は、環境を再作成してください。各モードで設定可能なリソースは以下のとおりです:
  • 共有モード:CPU 割り当て と 最大メモリ を変更できます。ルールは作成時と同様です。CPU を引き上げるとメモリの下限も引き上げられます。設定済みの最大メモリが新しい下限を下回る場合、フォームで先にメモリを引き上げるよう求められます。
  • 分離モード:CPU 割り当て(リソースプールのサイズ)のみ変更できます。引き下げる場合、アプリにすでに割り当てられている量を下回ることはできません。クォータを解放する必要がある場合は、先にアプリの CPU 割り当てを減らすか、アプリをデプロイ解除してください。リソースプールサイズを変更しても、環境内のアプリが再起動されることはありません。

アプリごとのリソース調整

分離モードでは、アプリごとに CPU とメモリを個別に設定できます。環境の詳細ページの アプリ タブで、対象アプリの行末にある … メニューをクリックし、リソースを編集 を選択します。共有モードではアプリごとのリソース調整はサポートされておらず、環境の編集 から環境のリソースを変更する必要があります。
分離モードのアプリにおけるリソース編集メニュー
  • CPU:0.1 vCPU 以上で、かつ環境のクォータから他のアプリへの CPU 割り当てを差し引いた量を超えない範囲で設定します。アプリのデプロイ時にはデフォルトで 0.5 vCPU が割り当てられます。デプロイ操作時には CPU 割り当てを選択できないため、リソースを編集 から調整してください。
  • 最大メモリ:フォームに表示される下限値以上にする必要があります。下限値は現在のアプリの CPU 割り当てによって決定されます。空欄の場合は、システムが CPU に基づいてデフォルト値を算出します。CPU を引き上げると下限値も引き上げられます。設定済みの最大メモリが新しい下限値を下回る場合、フォームで先にメモリを引き上げるよう求められます。
保存するとアプリが再起動し、その間は一時的に利用できなくなります。

アプリのデプロイ解除

詳細ページの アプリ タブの行末にある … メニューから デプロイ解除 を選択します。アプリが使用していたリソースは解放され、エンドポイントは直ちに外部へのサービスを停止します。デプロイ解除はバックグラウンドで実行され、デプロイ タブで進捗と結果を確認できます。 デプロイ解除操作は元に戻せません。サービスを復旧するにはアプリを再デプロイする必要があります。操作を行う前に、業務への影響を確認してください。

環境の削除

環境を削除すると、その API キー、Web アプリと API の設定、会話の記録も削除されます。この操作は元に戻せません。モードや名前空間を変更したい場合は、先に新しい環境を作成してアプリを再デプロイしてから、古い環境を削除してください。 環境カード、テーブル行の末尾、または詳細ページの右上にある … メニューから 削除 を選択します。環境内にデプロイ済みのアプリが存在する場合、削除することはできません。事前にすべてのアプリを個別に デプロイ解除 してください。実行中のデプロイ解除操作がある場合は、その操作が完了するまで待つ必要があります。削除後、環境が占有していた vCPU はプラットフォームの利用可能クォータに返却されます。