v2 基础 URL,调用时使用的密钥只对一个应用、一个环境有效。
基础 URL
所有部署环境共用一个v2 基础 URL,即把标准服务 API 地址中的 /v1 换成 /v2。打开应用的 访问点 标签页,任一部署环境的 后端服务 API 卡片上都能看到它。
认证
打开应用的 访问点 标签页,在该环境的卡片上生成 API 密钥,并作为 Bearer token 发送:staging,就用为 staging 生成的密钥。
已生成的 API 密钥在应用从环境下线后依然有效:下线期间调用会失败,重新部署到该环境后,原有密钥仍然可用。
支持的接口
部署环境只提供以下操作。在该基础 URL 上调用其他路径会返回404 not_found。
- Workflow 应用:
- Chatflow 应用:
- 两类应用通用:
错误
HTTP 错误响应示例:error 事件返回,具体格式见对应接口的说明。
每个操作具体会返回哪些错误码,见对应的参考页面。这组操作中有三种情况反复出现:
-
运行类和上传类操作(工作流的执行与停止、对话的发送与停止、文件上传)在密钥无效或部署不可用时,返回以下错误码:
-
会话管理和文件下载返回:
- 密钥无效时返回
401 unauthorized。 - 应用关闭了 API 访问,或在此环境中没有可用的部署时,返回
400 app_unavailable。
- 密钥无效时返回
-
工作流运行或对话请求超过该环境的最长执行时间(默认 20 分钟)时会停止,并返回
request_timeout:阻塞式返回时响应 HTTP 504,流式返回时则在事件流中收到一个status: 504的error事件。 该时限对应的配置项见 部署环境(App Runner) 中的enterprise.workflowMaxExecutionTimeSeconds。